1. Aktuell funktioniert unser Image Proxy nicht mehr ordnungsgemäß, sodass keine Bilder mehr angezeigt werden. Wir kümmern uns darum!

Wir verwenden Cookies, um deinen Aufenthalt auf Animes.so möglichst angenehm gestalten zu können. Mehr erfahren

VLC für OSX Zeigt Untertitel nicht an.

Dieses Thema im Forum "Computer & Technik" wurde erstellt von nickssystem, 29. Aug. 2017.

  1. nickssystem
    nickssystem

    Otaku Experte

    Registriert seit:
    23. Feb. 2014
    Beiträge:
    92
    Zustimmungen:
    15
    Wie in der Überschrift genannt, hab ich häufig das Problem das VLC unter OSX mir die Softsubs nicht anzeigt. das ganze lässt sich dann nur Lösen wenn ich das mit dem MAC Mediaplayer Abspiele. Da ich aber nur einen Player nutzen möchte, eben den VLC, ist mir die Lösung nicht wirklich genehm.

    Was bisher versucht wurde....

    - VLC Deinstallation und Neuinstallation
    - Zurücksetzten der Einstellungen
    - Testen älterer Versionen

    An meiner FONT Datenbank von OSX kann es nicht liegen, da ist so ziemlich jede Font vorhanden die es gibt. an der Hardware kann es auch nicht liegen, das ist ein dual Quadcore mit 32gb RAM, OSX 10.10.5 MacPro 2.1 und der Arbeitet absolut Stabil. Ich selbst kann das unter Windows nicht testen, da ich kein Windows habe. Und das OS neu aufsetzen ist Blödsinn.

    Jemand also ne Idee woran das jetzt liegen kann? Das Problem tritt häufig bei MKV Containern auf.

    Über feedback und Unterstützung würde ich mich freuen.
     
  2. beerus
    beerus

    Otaku Amateur

    Registriert seit:
    21. Aug. 2017
    Beiträge:
    12
    Zustimmungen:
    0
  3. nickssystem
    nickssystem

    Otaku Experte

    Registriert seit:
    23. Feb. 2014
    Beiträge:
    92
    Zustimmungen:
    15
    Das Bringt auch nichts. Das hatte ich als erstes mal versucht als ich mich durch diverse Foren gewühlt hab.

    Zum Anime selber kann ich jetzt mal ein Paar infos machen.

    Stream 0 ist ein ssa Untertitel
    Stream 1 ist die Video Spur
    Stream 2 ist die Audio Spur
    Stream 3 ist ein ssa Untertitel

    Ich kann ein Beispiel bereitstellen zum Selbst antesten.
     
  4. beerus
    beerus

    Otaku Amateur

    Registriert seit:
    21. Aug. 2017
    Beiträge:
    12
    Zustimmungen:
    0
    Schade, wäre ja auch zu einfach gewesen :D
    Ein Beispiel wäre an der Stelle nicht schlecht.
    Kann dann selbst mal VLC Player durchversuchen auf Mac, Win und Linux.
     
  5. nickssystem
    nickssystem

    Otaku Experte

    Registriert seit:
    23. Feb. 2014
    Beiträge:
    92
    Zustimmungen:
    15
    Ich hab in meinem Ökosystem halt nur Apple :D

    Wegen dem Beispiel muss ich mich erstmal an einen Moderator wenden ob ich das hier verlinken kann. Ansonsten dann via PN :)

    EDIT: Mod Angesprochen und Beitrag verlinkt :)

    Mal abwarten.....

    EDIT2: Erlaubnis erhalten :)

    Geschützter Bereich
    Registriere dich oder logge dich ein, um den Inhalt sehen zu können
     
    Zuletzt bearbeitet: 30. Aug. 2017
  6. so1ko
    so1ko

    ☣️ Anti-Spam-Bot & Troll vong Dienst ☢️ Seelenverkäufer Ex-Mitarbeiter

    Registriert seit:
    31. Aug. 2014
    Beiträge:
    488
    Zustimmungen:
    426
    Was ist in der Datei drin? Nur Untertitel? Wenn ja, dann einfach auf pastebin.com hochladen und den HIDE entfernen @nickssystem
    Oder schicks an @beerus per PN
     
  7. nickssystem
    nickssystem

    Otaku Experte

    Registriert seit:
    23. Feb. 2014
    Beiträge:
    92
    Zustimmungen:
    15
    Ich hab darum gebeten das ganze verlinken zu dürfen. Hierfür hab ich mich mit dem Link zu diesem Thread via PN an 00Ryuji00 gewandt. Bedingung war das ganze in HIDE zu setzten. Das hab ich eben auch gemacht.

    Zum einen kann so ergründet werden obs doch an meinem Mac bzw. Der VLC version liegt oder das File fehlerhaft Codiert ist.

    Demnach wäre ein bestehen lassen des Threads durchaus sinnvoll da auch andere User eben antesten können und demnach auch ihr Feedback abgeben können.
     
  8. so1ko
    so1ko

    ☣️ Anti-Spam-Bot & Troll vong Dienst ☢️ Seelenverkäufer Ex-Mitarbeiter

    Registriert seit:
    31. Aug. 2014
    Beiträge:
    488
    Zustimmungen:
    426
    Was ist denn jetzt in der Datei drin? Untertitel oder n Video?
    Beerus kann die Datei nicht sehen, weil er noch keinen Gefällt-Mir-Button hat. Wirst also keine Hilfe von ihm kriegen, außer du schickst es ihm per PN (wie gesagt). Kannst es ja trotzdem noch hier im Thread stehen lassen.
     
  9. nickssystem
    nickssystem

    Otaku Experte

    Registriert seit:
    23. Feb. 2014
    Beiträge:
    92
    Zustimmungen:
    15
    Ach, daher weht der Wind. Ja, ich lass es ihm Gesondert noch mal zukommen. Danke für den Hinweis. :)

    Edit: die Komplette 1. Episode so wie sie bei mir vorhanden ist.
     
  10. Windwusel
    Windwusel

    Invisible Otaku König

    Registriert seit:
    25. Jan. 2015
    Beiträge:
    243
    Zustimmungen:
    46
    Bevor du lange probierst würde ich den VLC abstoßen. Er verbraucht ohnehin zu viel Ressourcen und das Design ist schon immer unschön gewesen. Ich empfehle MPlayerX. Deutlich schlanker, schneller und effizienter. Kann mindestens das selbe.
     
  11. nickssystem
    nickssystem

    Otaku Experte

    Registriert seit:
    23. Feb. 2014
    Beiträge:
    92
    Zustimmungen:
    15
    Mag sein.... Anschauen kann ich ihn mir alle mal.

    Trotzdem wäre ne Problemlösung alle mal interessant. Da ich eben nicht der Typ bin der einfach "mal eben" so seine Gewohnheiten über den Haufen wirft ;)

    EDIT: Und nachdem sich MacKeeper gleich mit installiert hat, ich nicht gefragt wurde ob ichs mit installieren will, fliegt das gleich wieder von der Platte ;)

    TimeMaschine sei Dank....
     
    Zuletzt bearbeitet: 31. Aug. 2017
    so1ko gefällt das.
  12. Windwusel
    Windwusel

    Invisible Otaku König

    Registriert seit:
    25. Jan. 2015
    Beiträge:
    243
    Zustimmungen:
    46
    Für dein Problem kann es mehrere Ursachen geben. Fehleinstellung, Plugins oder eine andere App die in die Codecs eingreift. Schwer zu sagen aus der Ferne. Eine Neuinstallation des Players oder Starten aus der DMG wären mögliche Ansätze. Hier wäre eine Fernwartung sicher nicht uninteressant.
    Trotz allem findest du bestimmt Gefallen am MPlayerX :) Nimm aber nicht den aus dem App Store. Der ist veraltet und wird dort nicht mehr aktualisiert.

    Auch empfehlen kann ich Movist mit schönem Designpaket. Allerdings war der Player für meinen Geschmack etwas zu Funktionsreich. Zudem zu ineffizient.
     
  13. nickssystem
    nickssystem

    Otaku Experte

    Registriert seit:
    23. Feb. 2014
    Beiträge:
    92
    Zustimmungen:
    15
    VLC läuft bei mir Direkt ohne irgendwas zu ändern. Das einzige was ich änder ist die GUI von Hell auf Dunkel.

    Andere Codecs muss ich nicht installieren. Brauch ich auch nicht da hier der VLC alles bereitstellt was ich halt brauch. VLC ist ein Reiner Player für die Medien die ich nicht in die iTunes Lib. importiere. Mein Mac ist demnach Clean :) an dem Kann es nicht liegen.

    Und die GUI an sich ist mir eigentlich Schnuppe. Mich interessiert der Funktionsumfang und die Stabilität. Ich bin nicht umsonst vor etwas mehr als einem Jahrzehnt auf OSX umgestiegen ;)

    Mich würde eben interssieren ob VLC sich den fontcache aus den Vorhandenen Font's des Mac's erstellt. Sollte das nämlich der Fall sein, kann es gut möglich sein das die Font nicht vorhanden ist.... wäre also auch interessant zu wissen wie der Name der Font ist. VLC gibt mir ja da keine Info.

    So, ich hab ja noch Aegisub....

    Also Betreffende Matroskadatei geladen, Untertitel geladen(in dem Falle Stream 0) und abgeglichen ob die Fontfiles in meiner Fontlib. zu finden sind.

    Verwendet wurden:
    - Arial
    - Arial Bold
    - Arial Bold Italic
    - Times New Roman
    - Times New Roman Bold

    Nya, und sie sind alle vorhanden.

    Also kann die Fontlib. meines Mac's Ausgeschlossen werden.

    Was jetzt noch nen Versuch wert wäre, das ganze neu zu Muxen mittels HandBrake.

    Ich Berichte....

    Der erste Versuch beide Subs neu zu Muxen schlug schon mal Fehl. Zwar hat sich die Aufteilung der Streams verändert, ändert aber nichts an der Tatsache das die Subs nicht korrekt geladen werden.

    Also Muxe ich jetzt jeweils eine Spur separat.

    Was Definitiv Funktioniert ist das Einbrennen der Subs. Ist aber nicht Ziel der Handlung. Viele bevorzugen ja SoftSubs (AMV Produktion zb.)

    Ich Editiere den Betrag hier jetzt erstmal bis zur Lösung des Ganzen.

    Ich Berichte....
     
    Lasted edited by : 31. Aug. 2017
    so1ko gefällt das.
  14. blackshift
    blackshift

    Otaku Novize

    Registriert seit:
    26. Sep. 2012
    Beiträge:
    20
    Zustimmungen:
    2
    Schmeiß VLC weg, lad dir den Elmedia Video Player oder MXPlayer runter wenn du unter Mac Videos schauen willst.
    https://itunes.apple.com/de/app/elmedia-video-player/id1044549675?mt=12

    Hatte selbst mal einen Mac Mini (Mitte 2010) bis 2015/2016 - Nachdem ich Videos mit 1080p & 60fps nicht mehr richtig flüssig abspielen konnte, testete ich den Elmedia Video Player und Tada, die Subs erschienen wieder.

    Das Problem mit VLC liegt daran dass er die Subs-datei nicht richtig laden kann unter Mac.
    Vielleicht ist auch nur eine bezeichnung falsch beim Sub, ich würde aber mal einen anderen Player ausprobieren, bevor wir uns am MAC OS X ranwagen. Wenn das Problem weiterhin ist musst du mal gucken wegen ._Dateiname, falls dir das ( ._ ) etwas sagt.
     
  15. nickssystem
    nickssystem

    Otaku Experte

    Registriert seit:
    23. Feb. 2014
    Beiträge:
    92
    Zustimmungen:
    15
    Es gibt ein update zu dem Problem. Mit der Version 2.2.8 für OSX hat VLC ein Update ausgerollt was das Problem behoben hat.

    Wollt ich euch mal wissen lassen. Und damit das Problem nun auch als Behoben betrachtet werden kann.
     

Diese Seite empfehlen