1. Die erweiterte Suche funktioniert wieder. Die LiveSearch ist vorübergehend deaktiviert

Wir verwenden Cookies, um deinen Aufenthalt auf Animes.so möglichst angenehm gestalten zu können. Mehr erfahren

Frage mkvmerge: Mehrere Dateien mit gleichen Einstellungen muxen

Dieses Thema im Forum "Audio & Video Bearbeitung" wurde erstellt von Haxz0r, 30. Juli 2017.

  1. Haxz0r

    Haxz0r T3h Haxz0rz Skillz Nolife

    Registriert seit:
    15. Juni 2015
    Beiträge:
    654
    Zustimmungen:
    131
    Hallo zusammen,
    ich möchte gerne bei einem Ordner mit mehreren mkv-Files bestimmte Audio- und Untertitelspuren entfernen.

    Dazu habe ich bis jetzt immer das Tool mkvmerge (mkvtoolnix v13.0.0) benutzt und im jeweiligen Ordner
    folgendes Script in die Eingabeaufforderung eingefügt:


    for %f in (.\*) do G:\Programs\MKVToolNix\mkvmerge.exe -o "G:\Remux\%f" -a <audiospurID> --subtitle-tracks <subtitleID> --default-track <subtitleID> "%f"


    Bei den roten Stellen habe ich dann immer die Nummer der Spur eingegeben,
    die ich behalten möchte und schon wurden alle Files im Ordner mit den gleichen Spuren gemuxt.

    Jetzt hat sich aber bei Windows vor einiger Zeit die Eingabeaufforderung in die sog. PowerShell geändert
    und seit dem funktioniert es nicht mehr.

    Wenn ich die Files per Drag & Drop bei mkvtoolnix einfüge wird entweder alles zu einer Datei,
    oder aber es öffnet sich bei jeder Folge ein einzelner Tab und ich muss bei jeder Folge
    die Audio- & Untertitelspuren neu entfernen.

    Ich habe auch versucht, das Script über eine .bat Datei ausführen zu lassen, aber dann passiert nichts.


    Kann mir da jemand weiterhelfen?
     
    Zuletzt bearbeitet: 30. Juli 2017
  2. so1ko

    so1ko ☣️ Anti-Spam-Bot & Troll vong Dienst ☢️ Animes.so Staff Premium

    Registriert seit:
    31. Aug. 2014
    Beiträge:
    500
    Zustimmungen:
    447
    Zuletzt bearbeitet: 30. Juli 2017
    Haxz0r gefällt das.
  3. Haxz0r

    Haxz0r T3h Haxz0rz Skillz Nolife

    Registriert seit:
    15. Juni 2015
    Beiträge:
    654
    Zustimmungen:
    131
    Danke @so1k.
    Mein Problem lag darin, dass ich das Script in dem Ordner anwende und durch Shift + Rechtsklick
    nur die PowerShell angezeigt wird.

    Ich dachte die Eingabeaufforderung wurde durch diese ersetzt und bin deswegen nicht auf den Gedanken gekommen,
    es weiter über cmd zu machen. :yoyo103: